Zum Hauptinhalt springen

Droptables : Parameter und Tricks

1. Parameter

Um auf die Droptables , gehen Sie zu Komponenten > Droptables > Konfiguration > Haupteinstellungen

In den Optionen können Sie definieren:

 

  • Aktivieren Sie den Excel-Import / Export
  • Wählen Sie das Exportformat
  • Aktivieren Sie den Tooltip für Zellen
  • Aktivieren Sie das automatische Speichern in AJAX, andernfalls haben Sie eine Schaltfläche Änderungen speichern
  • Alternative Farbsätze: Zur Gestaltung Ihrer Daten verfügbar

 

droptables -Parameter

 

  • Zellenhervorhebung: Aktivieren Sie eine Farbe, wenn Sie mit der Maus über die Zelle fahren, um auf den ersten Blick den Zellinhalt zu sehen (Nur Zeile/Nur Spalte/Beide).
  • Hervorhebungsfarbe : Die Zelle, die die Hover-Farbe hervorhebt
  • Schriftfarbe hervorheben: Die Farbe der Hover-Schrift zur Hervorhebung der Zelle
  • Hervorhebungs-Deckkraft: Der Grad der Hervorhebungs-Deckkraft der Zelle
  • Ausgeblendetes rechtes Bedienfeld aktivieren: Ja/Nein
  • Periodizität der Tabellensynchronisierung: Verzögerung der automatischen Tabellensynchronisierung für Excel-Dateien oder Google Sheets
  • Datenbanktabelle aktivieren: Ja/Nein
  • Kategorien schließen: Die Tabellenkategorien Akkordeon automatisch schließen
  • Editor-Schaltflächen laden : Editor-Schaltflächen im HTML-Zelleditor laden

 

droptable-settings2

 

2. ACL-Berechtigung

Eine Joomla ACL-Integration ist verfügbar. Sie können jetzt den Zugriff auf Aktion oder Tabelle für Tabelleneditoren einschränken. Diese Einschränkung gilt für alle Tabellen.

 

Zugriffstabellen

 

Wenn Sie beispielsweise möchten, dass ein Administratorbenutzer nur auf seine eigenen Tabellen zugreifen und diese bearbeiten darf, setzen Sie „Bearbeiten“ auf „Verweigert“ und „Eigene bearbeiten“ auf „Zugelassen“. Sie können auch einschränken:

  • Die globale Konfiguration
  • Der Schnittstellenzugriff
  • Die Kategorieerstellung
  • Die Kategorielöschung
  • Die Kategorie Edition
  • Die Tabellenerstellung
  • Das Löschen der Tabellen
  • Edition / eigene Edition
Super Admin-Benutzer haben immer alle Editionsberechtigungen für alle Tabellen und Kategorien.

 

3. Laden Sie Tabellen in ein benutzerdefiniertes HTML-Modul

Droptables ist so konzipiert, dass es in jedem WYSIWYG-Editorfeld verwendet werden kann. Sie benötigen lediglich das aufzurufende Inhalts-Plugin. Meistens ist es standardmäßig aktiviert.

Wenn dies nicht wie beim benutzerdefinierten Joomla-HTML-Modul der Fall ist, müssen Sie es wie oben aktivieren.

 

Tabelle im Modul

 

Auf der Registerkarte Option müssen Sie die Option Inhalt vorbereiten auf: Ja setzen

 

4. Berechnung

Sie haben eine grundlegende Berechnungsimplementierung in Droptables . Verfügbare Elemente sind:

  • SUMME, TEILEN, MEHRFACH, ZÄHLEN, KONZAT
  • MIN, MAX, AVG  
  • DATUM, TAG, TAGE, TAGE360
  • ODER, XOR UND

Um eine Summe zu bilden, geben Sie Folgendes in eine Zelle ein (GROSSBUCHSTABEN sind obligatorisch): =SUMME(A1;B2) oder =SUMME(A1:B2)

Sie können das Berechnungsformat für alle Zellen in Tabellen festlegen. Sie finden die Optionen unter Menü Tabelle > Formatoptionen im Tabelleneditor.

 

Format-Optionen-Zellen

 

  • Datum Uhrzeit: Datumsformat für Datumsberechnungen einstellen

Datumsformat

  • Währungen:
    • Symbolposition: Um Zellenberechnungen für Geld durchzuführen, definieren Sie die Standardposition des Währungssymbols
    • Währungssymbol(e): Um Zellenberechnungen für Geld durchzuführen, definieren Sie das Standardwährungssymbol

Währungsoption

  • Dezimal und Zahl: 
    • Dezimalsymbol: Um die Zellenberechnung durchzuführen, definieren Sie das Standard-Dezimalsymbol
    • Dezimalzahl: Anzahl der Stellen nach dem Dezimalzeichen
    • Tausendersymbol: Um eine Zellenberechnung durchzuführen, definieren Sie das Standard-Tausendersymbol

Dezimalzahl-Option

 

5. Zugriffsbeschränkung für Zellen

Um zu verhindern, dass andere normale Benutzer einige wichtige Zellen bearbeiten können, können Sie neben der Administratorrolle auch bestimmte Benutzer zum Bearbeiten dieser Zellen auswählen. Sie können einer Tabelle mehrere Bereiche hinzufügen.

Zuerst sollten Sie Zellen auswählen, mit der rechten Maustaste darauf klicken und im Kontextmenü die Option Bereich schützen Oder Sie können zu Format > Bereich schützen gehen.

 

add-protect-range

 

Wählen Sie dann im Popup Benutzerrollen zum Bearbeiten berechtigt aus. Klicken Schaltfläche Bereich speichern Klicken Sie abschließend auf Schaltfläche Speichern & Schließen In diesem Fall kann nur die Autorenrolle diese Zellen bearbeiten, d. h. wenn andere Rollen auf diese Tabelle zugreifen, werden diese Zellen gesperrt und können sie nicht bearbeiten.