1. Hartstend
  2. Frågeställningar om WP Media Folder
  3. Fredag, juli 03 2020
  4.  Prenumerera via e-post
Hej,

din plugin ger några unika funktioner som anslutning till Google Foto till tabellen. Innan jag integrerade en sådan lösning på större webbplatser började jag fråga om erfarenheter med din lösning.
Efter att ha pratat med utvecklare runt omkring mig med ditt plugin fick jag rapporter om att det finns vissa problem med vissa tredjepartsprogram som du använder.

Ett exempel är Guzzle. Såvitt de vet, ser du inte till att den senaste guzzle används, till exempel här: https://nimb.ws/I2jUxc. I de flesta fall kommer detta att förbli irrelevant.
Den nuvarande versionen av Guzzle är 7.0 .1. Men ibland med äldre versioner leder detta till potentiella problem med andra plugin- eller lösningsleverantörer som använder Guzzle som baslösning.

Så frågan handlar om din policy för att uppdatera frekvenser för tredje parts programvara du använder.
Detta skulle hjälpa mig att förstå ditt tankesätt om detta och därför teknisk stabilitet i kombination med andra lösningar som använder Guzzle i Wordpress .

Tack.
Godkänt svarVäntar på moderering
Hej,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

Och tvärtom är det också sant, att använda senaste versioner kan leda till oförenlighet med andra plugins som använder gamla versioner : D
Tredje parter kan också vara bakåtkompatibla eller inte, etc. ...
Det är ett problem för WordPress plugins eftersom vi måste ta itu med tusentals andra plugins som också hanterar olika versioner av tredje parts kod.
Ärligt talat finns det ingen perfekt lösning eftersom vi måste ta itu med olika typer av kunder. Vissa användare har gamla plugin som inte underhålls längre men har inget annat val att behålla dem, andra har alla uppdaterade plugins, plugins laddar inte api / sdk på samma sätt ...
Vi behandlar också olika sdks, som ibland inte kan integreras som i koden för att undvika ett 20MB-plugin-paket (vilket skulle vara ett problem för de flesta användare).

För närvarande uppdaterar vi den på större version av vår plugin eller om vi känner till säkerhetsproblem eller oförenlighet.
Eftersom vi inte kan testa vårt plugin med alla befintliga andra plugins, kan vi ha inkompatibilitet då och då. Det är därför alla våra planer inkluderar tillgång till vårt supportteam och en utvecklare kommer att kontrollera problemet och lösa det med dig.
Självklart rekommenderar vi alltid våra kunder att testa alla uppdateringar på en stagingwebbplats innan, så att eventuell oförenlighet kan upptäckas och fixas innan produktionsstadiet.

Men detta är något vi har planerat att arbeta med och förbättra alla våra plugins.

Vänliga hälsningar,
Godkänt svarVäntar på moderering
Hej Damien,

tack för ditt mycket övertygande svar. Ja, du har helt rätt, du kan aldrig förhindra kompatibilitetsproblem.
När jag ser hastigheten på svaret på en fråga före försäljning är jag också övertygad om att supportteamet kommer att svara på ett snabbt sätt. Det här är det viktigaste för mig.

Tack för att du tog dig tid och var öppen om detta ämne. Kommer att överväga din lösning för framtida projekt.

vänliga hälsningar
  • Sida:
  • 1


Det finns inga svar på det här inlägget än.
Var en av de första som svarar på detta inlägg!