Sexta-feira, 03 de julho de 2020
  4 Respostas
  2 mil visitas
  Se inscrever
Olá,

seu plug-in traz alguns recursos exclusivos, como a conexão com o Google Fotos, para a mesa.
Antes de integrar uma solução como essa em sites maiores, comecei a perguntar sobre experiências com sua solução. Depois de falar com os desenvolvedores ao meu redor usando seu plug-in, fui informado que há alguns problemas relacionados a alguns softwares de terceiros que você está usando.

Um exemplo é Guzzle. Pelo que eles sabem, você não está garantindo que o Guzzle mais recente seja usado, por exemplo aqui: https://nimb.ws/I2jUxc .
Na maioria dos casos, isso permanecerá irrelevante. A versão atual do Guzzle é 7.0.1.

Mas, às vezes, usar uma versão mais antiga isso leva a problemas potenciais com outros plugins ou provedores de soluções que usam o Guzzle como sua solução base. Portanto, a questão é sobre sua política de atualização de frequências de software de terceiros que você está usando.
Isso me ajudaria a entender sua mentalidade sobre isso e, portanto, estabilidade técnica em combinação com outras soluções que usam o Guzzle no Wordpress.

Obrigada.
Oi,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

E o contrário também é verdadeiro, o uso de versões mais recentes pode levar à incompatibilidade com outros plugins usando versões antigas : D
Terceiros também podem ser compatíveis com versões anteriores ou não, etc ...
Isso é um problema para os plug-ins do WordPress, pois temos que lidar com milhares de outros plug-ins que também lidam com diferentes versões de código de terceiros.
Francamente, não existe uma solução perfeita, pois precisamos lidar com diferentes tipos de clientes. Alguns usuários têm plug-ins antigos que não são mais mantidos, mas não têm outra opção para mantê-los, outros têm todos os plug-ins atualizados, os plug-ins não carregam api / sdk da mesma maneira ...
Também lidamos com sdks diferentes, que às vezes não podem ser integrados, como no código, para evitar um pacote de plug-ins de 20 MB (o que seria um problema para a maioria dos usuários).

Atualmente, o atualizamos na versão principal do nosso plugin ou se estamos cientes de um problema de segurança ou de uma incompatibilidade.
Como não podemos testar nosso plugin com todos os outros plugins existentes, podemos ter incompatibilidades de tempos em tempos. É por isso que todos os nossos planos incluem um acesso à nossa equipe de suporte e um desenvolvedor verificará o problema e o resolverá com você.
Obviamente, sempre recomendamos que nossos clientes testem qualquer atualização em um site de teste antes, para que qualquer incompatibilidade possa ser detectada e corrigida antes do estágio de produção.

No entanto, isso é algo em que planejamos trabalhar e aprimorar todos os nossos plugins.

Cumprimentos,
H
1 ano atrás
Olá Damien,

obrigado por sua resposta convincente.
Sim, você está absolutamente certo, você nunca pode evitar problemas de compatibilidade. Ao ver a velocidade de resposta a uma pergunta de pré-venda, também estou convencido de que a equipe de suporte responderá de forma rápida.

Isso é o mais importante para mim. Obrigado por dedicar seu tempo e ser aberto neste tópico.

Considerará sua solução para projetos futuros. Atenciosamente
H
6 meses atrás
Olá Damien,

temos atualmente um projeto em que usamos 2 outros plug-ins com o Guzzle 7. Apenas gostaria de verificar com você qual versão do Guzzle você está usando atualmente em seu produto?
Cada versão abaixo de 7 tornaria seu plugin incompatível com nosso projeto.

https://github.com/guzzle/guzzle/issues/2744#issuecomment-716709685
https://github.com/Tropicalista/search-console/issues/1

Obrigado por me informar se você está usando o Guzzle versão 7 ou em caso você não faça se há um plano para atualizar algum cliente desatualizado.

Cheers
Hart
UMA
6 meses atrás
Olá Hartstend,

Obrigado por voltar para mim com mais informações.

temos atualmente um projeto em que usamos 2 outros plug-ins com o Guzzle 7. Só gostaria de verificar com você qual versão do Guzzle você está usando atualmente em seu produto?
Cada versão abaixo de 7 tornaria seu plugin incompatível com nosso projeto.

https://github.com/guzzle/guzzle/issues/2744#issuecomment-716709685
https://github.com/Tropicalista/search-console/issues/1

Obrigado por me informar se você está usando o Guzzle versão 7 ou em caso você não faça se há um plano para atualizar algum cliente desatualizado.


Nosso plugin está funcionando bem com o Guzzle versão 6.5, e iremos atualizar para a versão do Guzzle que contém o problema de segurança corrigido.


Muito obrigado!
Felicidades,
  • Página :
  • 1
Não há respostas para esta postagem ainda.
Seja um dos primeiros a responder a esta postagem!