1. Hartstend
  2. Forhåndsspørsmål om WP Media Folder
  3. Fredag 03 2020. juli
  4.  Abonner via e-post
Hallo,

pluginen din bringer noen unike funksjoner som tilkobling til Google Foto til tabellen. Før jeg integrerte en løsning som denne i større nettsteder begynte jeg å spørre om erfaringer med løsningen din.
Etter å ha snakket med utviklere rundt meg ved å bruke plugin-modulen min, fikk jeg beskjed om at det er noen problemer angående tredjepartsprogramvare du bruker.

Et eksempel er guzzle. Så vidt de vet, sørger du ikke for at den nyeste Guzzle brukes, for eksempel her: https://nimb.ws/I2jUxc. I de fleste tilfeller vil dette forbli irrelevant.
Den nåværende versjonen av Guzzle er 7.0 .1. Men noen ganger bruker eldre versjon dette potensielle problemer med andre plugin- eller løsningsleverandører som bruker Guzzle som baseløsning.

Så spørsmålet handler om policyen din for å oppdatere frekvenser for tredjepartsprogramvare du bruker.
Dette vil hjelpe meg å forstå tankesettet ditt om dette og derfor teknisk stabilitet i kombinasjon med andre løsninger som bruker Guzzle i Wordpress .

Takk skal du ha.
Akseptert svarVenter på moderering
Hei,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

Tvert imot er det også sant, å bruke siste versjoner kan føre til inkompatibilitet med andre plugins som bruker gamle versjoner : D
Tredjeparter kan også være bakoverkompatible eller ikke, osv ...
Det er et problem for WordPress plugins, da vi må håndtere tusenvis av andre plugins som også håndterer kode fra tredjeparter.
Helt ærlig er det ingen perfekt løsning, da vi har å gjøre med forskjellige typer kunder. Noen brukere har gammel plugin som ikke vedlikeholdes lenger, men har ikke noe annet valg å beholde dem, andre har alle oppdaterte plugins, plugins laster ikke inn api / sdk på samme måte ...
Vi behandler også forskjellige sdks, som noen ganger ikke kan integreres som i koden for å unngå en 20MB-plugin-pakke (noe som vil være et problem for de fleste brukere).

For øyeblikket oppdaterer vi den på hovedversjonen av pluginen vår, eller hvis vi er klar over sikkerhetsproblemer eller en inkompatibilitet.
Siden vi ikke kan teste plugin-modulen vår med alle eksisterende andre plugins, kan vi ha inkompatibiliteter fra tid til annen. Derfor inkluderer alle planene våre tilgang til supportteamet vårt, og en utvikler vil sjekke problemet og løse det med deg.
Vi anbefaler selvfølgelig alltid til kundene våre å teste enhver oppdatering på et iscenesettingsnettsted før, slik at eventuell inkompatibilitet kan oppdages og fikses før produksjonen.

Skjønt, dette er noe vi har planlagt å jobbe med og forbedre alle pluginene våre.

Med vennlig hilsen,
Akseptert svarVenter på moderering
Hei Damien,

takk for veldig overbevisende svar. Ja, du har helt rett, du kan aldri forhindre kompatibilitetsproblemer.
Når jeg ser hastigheten på svaret på et spørsmål før salg, er jeg også overbevist om at supportteamet vil svare på en rask måte. Dette er det viktigste for meg.

Takk for at du tok deg tid og var åpen om dette emnet. Vil vurdere din løsning for fremtidige prosjekter.

Med vennlig hilsen
  • Side:
  • 1


Det er ikke kommet noen svar på dette innlegget ennå.
Bli en av de første til å svare på dette innlegget!