1. Hartstend
  2. Vragen over de WP Media Folder over WP Media Folder
  3. Vrijdag 03 2020 juli
  4.  Schrijf je in via e-mail
Hallo,

uw plug-in brengt een aantal unieke functies zoals verbinding met Google Foto's naar de tafel. Voordat ik zo'n oplossing in grotere websites integreerde, begon ik te vragen naar ervaringen met uw oplossing.
Nadat ik met ontwikkelaars om me heen had gesproken met behulp van je plug-in, kreeg ik te horen dat er problemen zijn met bepaalde software van derden die je gebruikt.

Een voorbeeld is Guzzle. Voor zover u weet, zorgt u er niet voor dat de nieuwste Guzzle wordt gebruikt, bijvoorbeeld hier: https://nimb.ws/I2jUxc. In de meeste gevallen blijft dit irrelevant.
De huidige versie van Guzzle is 7.0 .1. Maar soms met een oudere versie leidt dit tot potentiële problemen met andere plug-in- of oplossingsproviders die Guzzle als hun basisoplossing gebruiken.

De vraag gaat dus over uw beleid om de frequenties van software van derden die u gebruikt bij te werken.
Dit zou me helpen om je mindset hierover en dus technische stabiliteit te begrijpen in combinatie met andere oplossingen die Guzzle in Wordpress .

Dank u.
Reacties (2)
Geaccepteerd antwoordIn afwachting van moderatie
Hoi,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

En het tegendeel is ook waar, het gebruik van de nieuwste versies kan leiden tot incompatibiliteit met andere plug-ins met oude versies : D
Derden kunnen ook achterwaarts compatibel zijn of niet, enz ...
Dat is een probleem voor WordPress plug-ins, omdat we te maken hebben met duizenden andere plug-ins die ook omgaan met verschillende versies van derden.
Eerlijk gezegd is er geen perfecte oplossing omdat we te maken hebben met verschillende soorten klanten. Sommige gebruikers hebben oude plug-ins die niet meer worden onderhouden, maar hebben geen andere keuze om ze te behouden, andere hebben allemaal up-to-date plug-ins, plug-ins laden api / sdk niet op dezelfde manier ...
We hebben ook te maken met verschillende sdks, die soms niet kunnen worden geïntegreerd zoals in de code om een ​​plug-in-pakket van 20 MB te vermijden (wat voor de meeste gebruikers een probleem zou zijn).

Momenteel werken we het bij op de belangrijkste versie van onze plug-in of als we ons bewust zijn van een beveiligingsprobleem of een incompatibiliteit.
Omdat we onze plug-in niet kunnen testen met alle bestaande andere plug-ins, kunnen we van tijd tot tijd incompatibiliteiten hebben. Daarom bevatten al onze plannen toegang tot ons ondersteuningsteam en zal een ontwikkelaar het probleem controleren en samen met u oplossen.
Natuurlijk raden we onze klanten altijd aan om eerder een update op een staging-website te testen, zodat eventuele incompatibiliteit vóór de productiefase kan worden gedetecteerd en verholpen.

Dit is echter iets waar we aan willen werken en al onze plug-ins willen verbeteren.

Vriendelijke groeten,
Geaccepteerd antwoordIn afwachting van moderatie
Hallo Damien,

bedankt voor je zeer overtuigende antwoord. Ja, u heeft helemaal gelijk, u kunt compatibiliteitsproblemen nooit voorkomen.
Aangezien ik de snelheid van het antwoord op een pre-salesvraag zie, ben ik er ook van overtuigd dat het ondersteuningsteam snel zal antwoorden. Dit is voor mij het belangrijkste.

Bedankt dat je de tijd hebt genomen om open te staan ​​over dit onderwerp. Zal uw oplossing overwegen voor toekomstige projecten.

Vriendelijke groeten
  • Bladzijde :
  • 1


Er zijn nog geen antwoorden op dit bericht.
Wees een van de eersten die op dit bericht reageert!