1. Hartstend
  2. Domande pre-vendita su WP Media Folder
  3. Venerdì 03 2020 luglio
  4.  Iscriviti via e-mail
Ciao,

il tuo plugin porta sul tavolo alcune caratteristiche uniche come la connessione a Google Foto. Prima di integrare una soluzione come questa in siti Web più grandi, ho iniziato a chiedere esperienze sulla tua soluzione.
Dopo aver parlato con gli sviluppatori intorno a me usando il tuo plugin, mi è stato riferito che ci sono alcuni problemi riguardanti alcuni software di terze parti che stai utilizzando.

Un esempio è Guzzle. A loro conoscenza, non ti stai assicurando che venga utilizzato l'ultimo Guzzle, ad esempio qui: https://nimb.ws/I2jUxc. Nella maggior parte dei casi, questo rimarrà irrilevante.
La versione attuale di Guzzle è 7.0 .1. Ma a volte usando una versione precedente questo porta a potenziali problemi con altri plugin o fornitori di soluzioni che usano Guzzle come soluzione di base.

Quindi la domanda riguarda la tua politica di aggiornamento delle frequenze del software di terze parti che stai utilizzando.
Questo mi aiuterebbe a capire la tua mentalità su questo e quindi la stabilità tecnica in combinazione con altre soluzioni che usano Guzzle in Wordpress .

Grazie.
Risposta accettataModerazione in attesa
Ciao,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

E il contrario è anche vero, l'uso delle ultime versioni può portare all'incompatibilità con altri plugin che utilizzano vecchie versioni : D
Terze parti possono anche essere retrocompatibili o meno, ecc ...
Questo è un problema per i plugin di WordPress quanto dobbiamo gestire migliaia di altri plugin anche con codice di terze parti di diverse versioni.
Francamente non esiste una soluzione perfetta in quanto dobbiamo trattare con diversi tipi di clienti. Alcuni utenti hanno plugin vecchi che non sono più mantenuti ma non hanno altra scelta per tenerli, altri hanno plugin aggiornati, i plugin non caricano api / sdk allo stesso modo ...
Ci occupiamo anche di diversi SDK, che a volte non possono essere integrati come nel codice per evitare un pacchetto di plugin da 20 MB (che sarebbe un problema per la maggior parte degli utenti).

Attualmente lo aggiorniamo sulla versione principale del nostro plugin o se siamo a conoscenza di problemi di sicurezza o incompatibilità.
Dato che non possiamo testare il nostro plugin con tutti gli altri plugin esistenti, di volta in volta possiamo avere incompatibilità. Ecco perché tutti i nostri piani includono un accesso al nostro team di supporto e uno sviluppatore verificherà il problema e lo risolverà con te.
Naturalmente consigliamo sempre ai nostri clienti di testare qualsiasi aggiornamento su un sito Web di gestione temporanea prima, in modo che eventuali incompatibilità possano essere rilevate e risolte prima della fase di produzione.

Tuttavia, questo è qualcosa su cui abbiamo pianificato di lavorare e migliorare tutti i nostri plugin.

I migliori saluti,
Risposta accettataModerazione in attesa
Ciao Damien,

grazie per la tua risposta molto convincente. Sì, hai perfettamente ragione, non puoi mai prevenire problemi di compatibilità.
Dal momento che vedo la velocità della risposta a una domanda pre-vendita, sono anche convinto che il team di supporto risponderà rapidamente. Questa è la cosa più importante per me.

Grazie per aver dedicato del tempo ed essere aperto su questo argomento. Considererà la tua soluzione per progetti futuri.

I migliori saluti
  • Pagina :
  • 1


Non ci sono ancora risposte per questo post.
Sii uno dei primi a rispondere a questo post!