1. Hartstend
  2. Preguntas previas a la venta sobre WP Media Folder
  3. Viernes 03 2020 de julio
  4.  Suscríbase por correo electrónico
Hola,

su complemento trae algunas características únicas como la conexión a Google Photos a la mesa. Antes de integrar una solución como esta en sitios web más grandes, comencé a preguntar sobre experiencias con su solución.
Después de hablar con los desarrolladores a mi alrededor utilizando su complemento, me informaron que hay algunos problemas con respecto a algún software de terceros que esté utilizando.

Un ejemplo es Guzzle. A su entender, no se está asegurando de que se utilice la última versión de Guzzle, por ejemplo aquí: https://nimb.ws/I2jUxc. En la mayoría de los casos, esto seguirá siendo irrelevante.
La versión actual de Guzzle es 7.0 .1. Pero a veces, el uso de una versión anterior genera problemas potenciales con otros proveedores de complementos o soluciones que usan Guzzle como su solución base.

Entonces, la pregunta es sobre su política de actualizar las frecuencias del software de terceros que está utilizando.
Esto me ayudaría a comprender su mentalidad sobre esto y, por lo tanto, la estabilidad técnica en combinación con otras soluciones que usan Guzzle en Wordpress .

Gracias.
Respuesta aceptadaModeración pendiente
Hola,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

Y lo contrario también es cierto, el uso de las últimas versiones puede generar incompatibilidad con otros complementos que usan versiones antiguas :RE
Los terceros también pueden ser compatibles con versiones anteriores o no, etc.
Ese es un problema para WordPress complementos de WordPress ya que tenemos que lidiar con miles de otros complementos que también se manejan con diferentes versiones de código de terceros.
Francamente, no existe una solución perfecta, ya que tenemos que tratar con diferentes tipos de clientes. Algunos usuarios tienen complementos antiguos que ya no se mantienen pero no tienen otra opción para mantenerlos, otros tienen complementos actualizados, los complementos no cargan api / sdk de la misma manera ...
También tratamos con diferentes sdks, que a veces no se pueden integrar como está en el código para evitar un paquete de complemento de 20 MB (lo que sería un problema para la mayoría de los usuarios).

Actualmente lo actualizamos en la versión principal de nuestro complemento o si conocemos un problema de seguridad o una incompatibilidad.
Como no podemos probar nuestro complemento con todos los otros complementos existentes, podemos tener incompatibilidades de vez en cuando. Es por eso que todos nuestros planes incluyen un acceso a nuestro equipo de soporte y un desarrollador verificará el problema y lo resolverá con usted.
Por supuesto, siempre recomendamos a nuestros clientes que prueben antes cualquier actualización en un sitio web provisional, para que cualquier incompatibilidad pueda detectarse y repararse antes de la etapa de producción.

Sin embargo, esto es algo en lo que hemos planeado trabajar y mejorar todos nuestros complementos.

Atentamente,
Respuesta aceptadaModeración pendiente
Hola damien

Gracias por su respuesta tan convincente. Sí, tiene toda la razón, nunca puede evitar problemas de compatibilidad.
Cuando veo la velocidad de la respuesta a una pregunta de preventa, también estoy convencido de que el equipo de soporte responderá de manera rápida. Esto es lo más importante para mí.

Gracias por tomarse su tiempo y ser abierto sobre este tema. Considerará su solución para futuros proyectos.

Atentamente
  • Página :
  • 1


Aún no hay respuestas para esta publicación.
¡Sé uno de los primeros en responder a esta publicación!