1. Hartstend
  2. Vorverkaufsfragen zu WP Media Folder
  3. Freitag, 03 2020. Juli
  4.  Abonnieren Sie per E-Mail
Hallo,

Ihr Plugin bringt einige einzigartige Funktionen wie die Verbindung zu Google Fotos auf den Tisch. Bevor ich eine solche Lösung in größere Websites integrierte, fragte ich nach Erfahrungen mit Ihrer Lösung.
Nachdem ich mit Entwicklern in meiner Umgebung über Ihr Plugin gesprochen hatte, wurde mir gemeldet, dass es Probleme mit der von Ihnen verwendeten Software von Drittanbietern gibt.

Ein Beispiel ist Guzzle. Nach ihrem Wissen stellen Sie nicht sicher, dass die neueste Guzzle verwendet wird, zum Beispiel hier: https://nimb.ws/I2jUxc. In den meisten Fällen bleibt dies irrelevant.
Die aktuelle Version von Guzzle ist 7.0 .1. Bei Verwendung einer älteren Version führt dies jedoch manchmal zu potenziellen Problemen mit anderen Plugin- oder Lösungsanbietern, die Guzzle als Basislösung verwenden.

Die Frage bezieht sich also auf Ihre Richtlinie zum Aktualisieren der Häufigkeit von Software von Drittanbietern, die Sie verwenden.
Dies würde mir helfen, Ihre Einstellung dazu und damit die technische Stabilität in Kombination mit anderen Lösungen zu verstehen, die Guzzle in Wordpress .

Vielen Dank.
Antworten (2)
Akzeptierte AntwortAusstehende Moderation
Hallo,


The current version of Guzzle is 7.0.1. But sometimes using older version this leads to potential problems with other plugin or solution providers who use Guzzle as their base solution.

Das Gegenteil ist der Fall. Die Verwendung der neuesten Versionen kann zu Inkompatibilitäten mit anderen Plugins führen, die alte Versionen verwenden : D.
Dritte können auch abwärtskompatibel sein oder nicht, etc ...
Dies ist ein Problem für WordPress Plugins, da wir uns mit Tausenden anderer Plugins befassen müssen, die auch mit Code von Drittanbietern unterschiedlicher Version umgehen.
Ehrlich gesagt gibt es keine perfekte Lösung, da wir uns mit verschiedenen Arten von Kunden befassen müssen. Einige Benutzer haben alte Plugins, die nicht mehr gepflegt werden, aber keine andere Wahl haben, um sie zu behalten, andere haben alle aktuellen Plugins, Plugins laden api / sdk nicht auf die gleiche Weise ...
Wir beschäftigen uns auch mit verschiedenen SDKS, die manchmal nicht wie im Code integriert integriert werden können, um ein 20-MB-Plugin-Paket zu vermeiden (was für die meisten Benutzer ein Problem darstellen würde).

Derzeit aktualisieren wir es auf der Hauptversion unseres Plugins oder wenn uns ein Sicherheitsproblem oder eine Inkompatibilität bekannt ist.
Da wir unser Plugin nicht mit allen vorhandenen Plugins testen können, kann es von Zeit zu Zeit zu Inkompatibilitäten kommen. Aus diesem Grund sehen alle unsere Pläne einen Zugang zu unserem Support-Team vor, und ein Entwickler wird das Problem prüfen und mit Ihnen lösen.
Natürlich empfehlen wir unseren Kunden immer, Updates auf einer Staging-Website vorher zu testen, damit Inkompatibilitäten vor der Produktionsphase erkannt und behoben werden können.

Wir haben jedoch geplant, an all unseren Plugins zu arbeiten und diese zu verbessern.

Freundliche Grüße,
Akzeptierte AntwortAusstehende Moderation
Hallo Damien,

Vielen Dank für Ihre sehr überzeugende Antwort. Ja, Sie haben völlig Recht, Sie können Kompatibilitätsprobleme niemals verhindern.
Da ich die Geschwindigkeit der Antwort auf eine Frage vor dem Verkauf sehe, bin ich auch davon überzeugt, dass das Support-Team schnell antworten wird. Das ist das Wichtigste für mich.

Vielen Dank, dass Sie sich Zeit genommen haben und offen für dieses Thema sind. Wird Ihre Lösung für zukünftige Projekte in Betracht ziehen.

Freundliche Grüße
  • Seite :
  • 1


Für diesen Beitrag wurden noch keine Antworten abgegeben.
Sei einer der Ersten, der auf diesen Beitrag antwortet!